注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

北边的风

IT 钓鱼 养生

 
 
 

日志

 
 

cisco路由器单接口的nat配置(转)  

2013-06-26 16:20:40|  分类: IT心得 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

条件:

1、IOS在12.1(5)T9及以上版本。更低版本未做验证。

2、至少具有两个或多个ISP提供的的global地址。

实现思路:

1、将ISP提供的地址作为secondary地址配置在以太接口上。该以太接口同时作为inside接口。作为内部主机的网关。

2、 创建一个loopback接口做为nat的outside.

3、使用route-map,强行将内部网出去的数据包及从外部返回的对应数据包路由到loopback接口。

实例:

拓朴如下图所示:

cisco路由器单接口的nat配置(转) - jujiong - 水神之家
配置如下:

interface Loopback0

  ip address 172.16.2.254 255.255.255.252

  ip nat outside

!

//创建一个loopback接口,并作为NAT outside接口。

interface Ethernet0

  ip address 192.168.0.1 255.255.255.248 secondary

  ip address 172.16.1.254 255.255.255.0

  ip Nat inside

  ip policy route-map rm-nat

!

//在E0接口上配置172.16.1.254做为IP,同时将ISP提供的地址做为Secondary地址。e0做为inside接口。

在本接口上应用rm-nat这个route-map

ip nat pool pool1 192.168.0.2 192.168.0.3 prefix-length 29

ip nat inside source list 10 pool pool1 overload

//常规NAT配置

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.6

ip route 172.16.1.0 255.255.255.0 Ethernet0

access-list 10 permit 172.16.1.0 0.0.0.255

//配置路由及NAT所需要的access-list

access-list 101 permit ip 172.16.1.0 0.0.0.255 any

access-list 101 permit ip any 192.168.0.0 0.0.0.7

//配置route-map所需要的acl。第一句匹配出去的包,第二句匹配返回的包。

route-map rm-nat permit 10

  match ip address 101

  set ip next-hop 172.16.2.254

//配置所需要的route-map,凡是满足access-list 101条件的包均被转发到172.16.2.254(loopback0接口)。


站长资讯网
  评论这张
 
阅读(436)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017